Forum has been upgraded!

#22
Hi everyone,

Thank you for your patience (and long time no speak!)

You'll be pleased to know that the forum has been upgraded, and any issues regarding attachments should be resolved. I'll work on reskinning when I can, but I didn't see any reason for that to delay re-opening now that the upgrade is done. For the next couple of hours you may experience some issues where old attachments or avatars don't load while the old data is being relinked to its new location, but otherwise the forum should operate fine (in fact, better!)

Mobile functionality & Tapatalk should also be fine, and generally you should notice a bunch of new features.

Enjoy!
Any chance we can have the option to change our user name? Pweeeeeeze! <3
 

lurk

Well-Known Member
#27
Ahh fantastic, thanks man. Really appreciate you being active here post upgrade to make sure it's all smooth.

Hey everyone, if you've bookmarked this forum just change it to "https://www.robchapman.tv/forum/" and you'll get the secure stuff.
Thing is, it's fine changing your bookmarks, but if you visit the home page from the menu above, you'll e taken back to a non secure http page, and visit the forum from the link on the home page you'll be back here using http as well. Those two links need updating to https. And mixed content needs sorting on all the home page stuff as well by the look of it.

It really needs to be forcing https via htaccess, especially as you can fill in a form with billing details, and purchase stuff from that home page.
 

ThePriseInferno

Well... does it?
#28
Thing is, it's fine changing your bookmarks, but if you visit the home page from the menu above, you'll e taken back to a non secure http page, and visit the forum from the link on the home page you'll be back here using http as well. Those two links need updating to https. And mixed content needs sorting on all the home page stuff as well by the look of it.

It really needs to be forcing https via htaccess, especially as you can fill in a form with billing details, and purchase stuff from that home page.
Just took a gander - it looks like they're redirecting to PayPal for actual processing of the payment, so in theory the main website doesn't *need* HTTPS (except, uh, it's 2019 now - *everything* needs HTTPS). That said, that particular issue is solved by simply updating the hyperlink that the "home" button points to in the theme settings for XenForo, along with updating the links in the HTML source on the main website pointing back here.

Interestingly, even if you browse to the main site using HTTPS, you still don't get the coveted "green lock icon" because the page is pulling content over HTTP (I believe it's a couple of pictures as well as stuff from Soundcloud), so all of that would need to be fixed too.

EDIT: Oh, reading your reply more closely, this is all stuff that you literally just posted. Nothing to see here, move along... ;)

I'm also gonna go ahead and set my alarm for March 28th to script out a reply to @Darfuria asking if he's renewed the certificate yet. :p
 

lurk

Well-Known Member
#29
Just took a gander - it looks like they're redirecting to PayPal for actual processing of the payment, so in theory the main website doesn't *need* HTTPS (except, uh, it's 2019 now - *everything* needs HTTPS). That said, that particular issue is solved by simply updating the hyperlink that the "home" button points to in the theme settings for XenForo, along with updating the links in the HTML source on the main website pointing back here.

Interestingly, even if you browse to the main site using HTTPS, you still don't get the coveted "green lock icon" because the page is pulling content over HTTP (I believe it's a couple of pictures as well as stuff from Soundcloud), so all of that would need to be fixed too.

EDIT: Oh, reading your reply more closely, this is all stuff that you literally just posted. Nothing to see here, move along... ;)

I'm also gonna go ahead and set my alarm for March 28th to script out a reply to @Darfuria asking if he's renewed the certificate yet. :p
Mixed content is coming from the forms on the home page etc. Regarding the cert, it's only using lets encrypt, so if host is any good it'll renew without intervention like it does with my one.

You can see where the problems are by running the secure site addy through, https://www.whynopadlock.com/
 

ThePriseInferno

Well... does it?
#30
Mixed content is coming from the forms on the home page etc. Regarding the cert, it's only using lets encrypt, so if host is any good it'll renew without intervention like it does with my one.

You can see where the problems are by running the secure site addy through, https://www.whynopadlock.com/
I run all of my sites on VPSes so I had no idea that some providers will renew LE certs without intervention. That's super cool! Was also unaware of that padlock checking site - cheers, that's gonna come in handy :)
 
Top